Jump to content
TUFLOW Forum

Robin.Green

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Robin.Green

  • Rank
    Member

Recent Profile Visitors

1294 profile views
  1. Hi There I have been sent a multi-domain TUFLOW model with embedded 1D river channels in ESTRY and Flood Modeller (ISIS). The simulations complete with no issues when using 2013-12-AD, but they fail at the first time step when using 2016-03-AA. No error code is generated in the .tlf, I am just presented with a Fortran Error associated with the TUFLOW executable. I have tried to work round the issue by using a "DEFAULTS ==PRE 2016" command, but the simulation still fails. Has anyone else encountered such a scenario? Cheers!
  2. Hi All I am in the process of modelling an inverted siphon (depressed sewer) within ESTRY, and before I get too far I thought I should stick up a post to see if anyone was aware of any 'special measures' this required. The upstream side of the siphon is to be connected to the 2D domain, and the downstream side to a 1D pipe network. I am proposing to model the siphon using two pipe nwk lines which meet at the siphons invert. So the pipe on the downstream side will have an adverse gradient (forming a v-shape under the road). I am hoping that this approach should avoid any overly short/steep reaches. As I say, just interested to hear of anyone else's experience modelling such a structure. Cheers
  3. Problem Solved. I found a simple solution which just required removing the water levels from the logic. Instead they are specified separately as variables, as shown below: Define Pump Control == Pump_House !---------------deafult Setting ------------ Pump operation == off Pump Capacity == 0.591 ! capacity in cums Pump period (min) == 1 ! time to start Pump number == 2 ! No of pumps !Set user variable Water_Level == H1D BD2.2 Upper == -1.3 Lower == -2.0 ! Logic if Water_Level > Upper ! trigger level to start pump Pump operation == on else if Water_Level < Lower ! trigger level to stop pump Pump operation == off else Pump operation == no change end if End Define
  4. Hi there - I'm after some advice in relation to an operation pump I have within my model. The pump is controlled by the upstream water level, and I have a working definition as follows: Define Pump Control == Pump_House !---------------deafult Setting ------------ Pump operation == off Pump Capacity == 0.591 ! capacity in cums Pump period (min) == 1 ! time to start Pump number == 2 ! No of pumps !Set user variable Water_Level == H1D BD2.2 ! Logic if Water_Level > 0.5 ! triger level to start pump Pump operation == on else if Water_Level < 0.1 ! triger level to stop pump Pump operation == off else Pump operation == no change end if End Define In reality the pump needs to start at a water level of -1.3 and stop at -2.0. When I set the variables to these values I am presented with the following error, as if TUFLOW cannot recognize a negative value?: “NoXY: ERROR 1513 - Input variable in line below has not previously been defined. Operating Control Line = if Water_Level > -1.3; Operating Control Input Variable = http://wiki.tuflow.com/index.php?title=TUFLOW_Message_1513” Has anyone else encountered such an issue, or does anyone know a solution? Many thanks for your help. Robin
  5. Hi there I am building a model of a culverted watercourse with small isolated reaches of open watercourse. There are some complex structures in the opens reaches (such as siphons) so I have used ISIS for these, however ISIS has struggled with the long culverted reaches - therefore this is modelled within ESRTY. The floodplain is modelled within TUFLOW. The ESTRY and ISIS components connect directly using the X1DH (from ESTRY to ISIS) and X1DQ (from ISIS to ESTRY) boundaries. The hydrological units in ISIS provides the inflow to the system. I have generated some initial conditions for ESTRY by running a baseflow event and creating a restart file. The model runs, and the ISIS model reports no problems, the 1D and 2D elements report no negative depths, and the _TSMB.mif layer shows all 0's (i.e.: the ME_Avg_Abs attribute is 0 for all nodes). The DOS console and .TLF show that all 3 CE results (total, 1D and 2D) start at 0%, but the "total CE" increases to 57% over the first hour of the simulation (before any 2D cells are activated), despite the "1D CE" = 0.2% and the "2D CE" = 0.0%. As the flood flows pass through the model over the next 4hours the total CE reduces to 8%, the 1D CE reduces to 0.0%, and the 2D CE increases to 4% (which I'm sure I can resolve). If I deactivate the .TRF restart file (ESTRY initial conditions) the total CE starts at 100% before slowly reducing through the simulation. If I ignore the total CE, the individual 1D and 2D CE appear fairly healthy, so I'm unsure what is causing the extremely high total CE. As I have no negative depths, or messages to review and the _TSMB.mif layer is blank I don't know what is causing the degree of CE. Any help is much appreciated. TUFLOW: 2011-09-AF-w64-iSP ISIS: 3.5.1
  6. Hi there I'm having a bit of trouble extracting a ZUK0 asc grid from the .XMDF format. I can successfully use TUFLOW_to_GIS to extract H & D datasets, but setting the 'type' to ZUK0 results in the following error: "Unable to interpret Map Output Data Type: "ZUK0". I am able to open this dataset without issue within SMS. Has anyone else experienced this, and do you know of a fix? I'm currently using build 2011-05-AA of TUFLOW_to_GIS, as when I haved tried using 2011-08-AA I get the error "unable to read data" for all datasets. Cheers Rob
  7. Hi There - I’m fairly new to SMS, and I am currently trialling SMS 11.0 beta. I have a large site which is covered by multiple aerial photos which I’d like to drape over my TUFLOW mesh. In plan view I can see all the images, but as I rotate the view SMS will only let me view one of the draped photos at a time. Is there a way of allowing multiple draped images to be viewed at once? If this is not possible then does anyone know of a good method/programme for combining aerial photos without losing their geo-referencing or quality? Thanks in advance.
  8. Thanks again for the help Unfortunatley there are no iterpolates within the ISIS model - although I have made a mental note of this issue for future projects! Instead I followed your suggestion of using the xWLLp check file to generate a WLL points file, which has worked a treat. Cheers Rob.
  9. Thanks Peter - that brought the channel back to earth. However, at certain locations I am getting 'spikes' in the bank-top of the channel (see attached pic). I don’t suppose you know what could be causing these? My ISIS sections do not have elevations as high as these nor do my zlines, and the resulting water surface does not seem to relate to them either. Thanks again Rob.
  10. Hi there - I'm just wondering if there is a similar command for resetting the WLL offset when linking to an ISIS 1D model? Cheers Rob.
  11. Thanks for the response. I agree that the infiltration rate of the trenches will be less than the sheet flow across the site. However, the stone filled trenches will be laid at a gradient to convey flows towards an attenuation pond - with the aid of a piped system at its base. It is possible that the trenches could be insufficient to intercept all of the sheet flow; however it is still desirable to model them to establish any short fall to inform the development of the site.
  12. Hi there We are currently modelling a proposed development which incorporates stone filled trenches with a perforated pipe at the base, to intercept and convey overland flow routes to attenuation ponds - and my question relates to the most suitable way to model the trenches. We have adopted a 2m grid and the trenches are likely to have a 1m width. Out initial thoughts are to model the ditch in the 2D using a FC_Shape and apply a high blockage: to firstly represent the trench width, which will be half that of the cell size; and secondly to represent the approx void space of the stone fill - but we are unsure on the suitable loses to represent the limited conveyance resulting from the stone fill? The pipe network at the base of the ditch could be inserted within ESTRY with connections to the 2D at regular intervals to allow inflow. To simplify this could we just adopt the FC_Shape and incorporate the pipe network by reducing the blockage and loses within its attributes? Or would it better to model the whole lot within ESTRY and apply a 1D channel on top of the 1D pipe work along with suitable loses/blockages? Do these seem like appropriate methodologies? Has anyone else had a similar experience, and what approach did you adopted? Any help/advice is greatly appreciated.
  13. Just an update on this post - the HX liness were compared with the 1D channel length, there were only marginal differences, but these were corrected. The 1D channel widths were also checked - these were largely just over 10m (2 cells), but adding an additional few meters to the channel width was shown to resolve the circulating flow. Thanks again for your help!
  14. Thanks for the speedy reply, and the explanation. Just for clarification - the problem occurs upstream of the embankment where water is pooling behind the structure (sorry for the poor explanation), but I guess that your explanation and solution still apply; as the confined conditions and large flows may exacerbate the situation further? The 1D channel width is roughly 2x cell size, but due to the large flows and relatively deep flood depths (1D channel depth= ~1m, 2D flood depths= ~1m) perhaps it would be worth extending the ISIS width further to provide some more volume? I also note the need to double check reach lengths against HX boundary lengths - I think I'm going to have a busy Monday morning! Many thanks for the help - I'll let you know how it goes. Cheers Rob
×
×
  • Create New...