Jump to content
TUFLOW Forum

Search the Community

Showing results for tags 'flux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • About This Forum and Announcements
    • How to Use This Forum
    • Forum Feedback
    • Announcements
  • TUFLOW Modelling
    • 1D/2D Linking
    • 1D Domains
    • 2D/2D Linking
    • 2D/2D Nesting
    • 2D Domains
    • Boundaries
    • Documentation & Tutorial Model
    • Dongles/Licensing/Installation
    • Ideas / Suggestions / New Features
    • Mass Balance/Mass Error
    • MATH Errors & Simulation Failure
    • Restart Files
    • Post-Processing
    • Software/Hardware Requirements
    • Text Files (.tcf, .tgc, .tbc, .ecf)
    • Utilities
    • Miscellaneous
  • Other Software
    • ISIS-TUFLOW
    • MapInfo/Vertical Mapper
    • miTools
    • Other GIS/CAD
    • SMS
    • XP-SWMM2D
    • UltraEdit/Excel
    • TUFLOW Apps

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hello, I am trying to use the TUFLOW plugin flux plot tool to plot flow from the xmdf's depth layer. I followed the example shown in the TUFLOW wiki: https://wiki.tuflow.com/index.php?title=TUFLOW_Viewer#Plotting_Flow Drawing the flux line works fine, but when I right click to end the line, it either displays zero for the entire time period, or produces the python error copied below. This occurs for a line drawn on both the max depth result and depth at a time. There should be data there, as the PO line shows a hydrograph. I tried this in a blank QGIS map, with projection set and xmdf projection set, and in my working QGIS file. I tried this with multiple xmdf results files. QGIS version: 3.8.2 TUFLOW plugin version: 3.0.4.1 Output is xmdf results every 30 min for 24hrs; other TUFLOW plugin viewing utilities (cross section, timeseries) work well TypeError: 'float' object is not subscriptable Traceback (most recent call last): File "C:/Users/jmital/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\tuflow\tuflowqgis_tuviewer\tuflowqgis_tuflowline.py", line 255, in rightClick self.createMemoryLayer() File "C:/Users/jmital/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\tuflow\tuflowqgis_tuviewer\tuflowqgis_tuflowline.py", line 330, in createMemoryLayer worked = self.tuPlot.tuPlot2D.plotFlowFromMap(None, feat) File "C:/Users/jmital/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\tuflow\tuflowqgis_tuviewer\tuflowqgis_tuplot2d.py", line 602, in plotFlowFromMap velMag = velDataValue[0] TypeError: 'float' object is not subscriptable
×
×
  • Create New...