Jump to content
TUFLOW Forum
Claire

Visual fortran runtime error

Recommended Posts

I have been having a problem with my ISIS-Tuflow runs which generates the attached visual fortran runtime error, resulting in the termination of the simulation. This error initiates in one simulation, and then spreads through all running simulations when they reach their next save interval.

These runs relate to a project which has been ongoing for the last 6 months, therefore I am running ISISv3.2 with Tuflow 2008-08-AJ for version compatibility across the project.

I know that both ISIS and Tuflow contain a version of the libifcoremd.dll and have tried ensuring that the same version of the file is contained within both programs with no success.

There is plenty of space remaining on the U: drive to which the results are written so the drive being full has been ruled out as a cause.

I have also checked the connectivity of the U: drive after the first failure by pausing all runs, and checking whether there is access to U: drive from the machine running the simulations, which there has been, and then restarting the runs, however they still fail in the same manner at their next save interval.

I have been in contact with ISIS support and they are out of suggestions as to the cause of problem

Does anyone have any thoughts or suggestions?

Claire

post-2339-1267006405_thumb.png

Share this post


Link to post
Share on other sites

Hiya,

I have had the same problem with my models since I have started using the latest ISIS and TUFLOW versions. It seems that when I am running a model on one machine and the drive to which the result is being written is on another network computer, this visual fortran error pops up at some point in the simulation. I have managed getting around this problem by using a storage drive that is directly attached to the machine from which I am running my models.

Hope this helps until the developers crack on this issue.

Best of luck :)

Tibebu

Share this post


Link to post
Share on other sites

Claire,

I have been having exactly the same problem. I've also raised it with ISIS support and have not got a solution so far. It always seems to happen when running multiple simulations on one machine and calls a fortran error regardless of whether it is the ISIS results or the TUFLOW results being written to an external hard drive. I have been using ISIS v3.3 and TUFLOW 2009-07-AE iSP. For extremely large model simulations it also seems to produce a memory error when allocating memory for the 1D domain at the beginning of the run. I have managed to fix both these problems by writing all results to my C drive which is not ideal because there is not much space. In the event of needing several runs done quickly I have had to use several computers instead of batch running on one just to ensure that they complete!

Matt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...